码迷,mamicode.com
首页 > 其他好文 > 详细

poj1273

时间:2014-08-27 10:55:07      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:网络流   poj   bfs   

Drainage Ditches
点击打开链接
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 56466   Accepted: 21694

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

题意:

赤裸裸的网络流题目。给定点数,边数,每条

边的容量,以及源点,汇点,求最大流。

可以用来当做网络流的入门题。

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 500
#define INF 100000000
int n, m, s, t;
int a[maxn];
int p[maxn];
int cap[maxn][maxn];
int flow[maxn][maxn];
int main()
 {
    while(~scanf("%d%d",&m,&n))
    {
     memset(cap,0,sizeof(cap));
     for(int i = 0; i < m; i++)
     {
        int u, v, c;
        scanf("%d%d%d", &u, &v, &c);
        cap[u][v] += c;
     }
      s = 1;
      t = n;
      int ans = 0;
      queue<int> q;
      memset(flow, 0, sizeof(flow));
      for(;;)
        {
        memset(a, 0, sizeof(a));
        a[s] = INF;
        q.push(s);
        while(!q.empty())   //bfs找增广路
        {
          int u = q.front(); 
          q.pop();
          for(int v = 1; v <= n; v++) if(!a[v] && cap[u][v]>flow[u][v])
          {                            //找到新节点V并入队
            p[v] = u; q.push(v);       
            if(a[u]<cap[u][v]-flow[u][v])   //s-v上最小残量
            a[v]=a[u];
            else
                a[v]=cap[u][v]-flow[u][v];
          }
        }
        if(a[t] == 0) break;         //找不到,则当前已经是最小残量
        for(int u = t; u != s; u = p[u])  //更新流量
        {
          flow[p[u]][u] += a[t];
          flow[u][p[u]] -= a[t];
        }
        ans += a[t]; //更新从S流出的总流量
      }
      printf("%d\n", ans);
}
  return 0;
}



poj1273

标签:网络流   poj   bfs   

原文地址:http://blog.csdn.net/u013712847/article/details/38866721

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!