码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3616 Milking Time

时间:2017-05-20 10:10:25      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:arm   describe   val   ber   value   names   input   include   width   

Language:
Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9534   Accepted: 3958

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
题目很简单,类比最长上升子序列做就行
#include <iostream>
#include <cmath>
#include <cstring>
#include <iomanip>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node
{
    int b_time;
    int e_time;
    int milk;
}a[1010];
int dp[1010];
bool cmp(Node a,Node b)
{
    return a.e_time<b.e_time;
}
int main()
{
    int n,k,res;
    cin>>n>>k>>res;
    for(int i=0;i<k;i++)
        cin>>a[i].b_time>>a[i].e_time>>a[i].milk;
    sort(a,a+k,cmp);
    for(int i=0;i<k;i++)
    {
        dp[i]=a[i].milk;
        for(int j=0;j<i;j++)
            if(a[j].e_time+res<=a[i].b_time&&dp[j]+a[i].milk>dp[i])
            dp[i]=(dp[j]+a[i].milk);
    }
    cout<<*max_element(dp,dp+k)<<endl;
}

  

poj 3616 Milking Time

标签:arm   describe   val   ber   value   names   input   include   width   

原文地址:http://www.cnblogs.com/masterchd/p/6881250.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!