码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1260:Tickets(DP)

时间:2017-05-20 19:31:53      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:int   ref   orm   namespace   vector   ota   ase   margin   状态转移方程   

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 923    Accepted Submission(s): 467


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible?

If so, I guess Joe would full of appreciation for your help.

 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
2 2 20 25 40 1 8
 

Sample Output
08:00:40 am 08:00:08 am


解题思路:

一个人能够单独买票花费一定的时间,也能够两个人一起买票,也给定一个时间。给出K个人的单独买票时间和K-1个相邻的两个人一起买票的时间。问一共花费的最小时间。

用one[i]为每一个人单独买票的时间,two[ i+1]为两个人一起买票的时间。

状态转移方程为: dp[i] = min(dp[i-1]+one[i] , dp[i-2] + two[i] )。当前第i个人分为两种情况。一是单独买,而是和前面的一块买。

另外注意最后的输出。




#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

const int maxn = 2000 + 50;

int n;
int k;
int dp[maxn];
int one[maxn];
int two[maxn];

int main()
{
    scanf("%d", &n);
    while( n-- )
    {
        memset(dp, 0, sizeof(dp));
        memset(one, 0, sizeof(one));
        memset(two, 0, sizeof(two));
        scanf("%d", &k);
        for(int i=1; i<=k; i++)scanf("%d", &one[i]);
        for(int i=2; i<=k; i++)scanf("%d", &two[i]);
        dp[0] = 0;dp[1] = one[1];
        for(int i=2; i<=k; i++)dp[i] = min( dp[i-1]+one[i], dp[i-2]+two[i] );
        int h = dp[k] / 3600 + 8;
        int m = dp[k] / 60 % 60;
        int s = dp[k] % 60;
        printf("%02d:%02d:%02d am\n", h, m, s);
    }

    return 0;
}





HDU 1260:Tickets(DP)

标签:int   ref   orm   namespace   vector   ota   ase   margin   状态转移方程   

原文地址:http://www.cnblogs.com/brucemengbm/p/6882892.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!