码迷,mamicode.com
首页 > 其他好文 > 详细

破解2559

时间:2017-05-20 21:53:32      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:cas   min   splay   seq   sequence   string   clu   height   center   

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:       
技术分享

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.      

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.     

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.      

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

 

题意:给你一系列的矩形。宽度都为1。高度为h要求出相邻矩形连成的最大矩形面积。

思路:

假设确定了长方形的左端点L和右端点R,那么最大可能的高度就是min{hi|L <= i < R}。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int const maxn=100010;
long long  h[maxn],left[maxn],right[maxn];
void solve()
{
    int n,temp;
    while(scanf("%d",&n)==1&&n)
    {
        memset(h,0,sizeof(h));
        memset(left,0,sizeof(left));
        memset(right,0,sizeof(right));
         for(int i=1;i<=n;i++)
            scanf("%I64d",&h[i]);
         for(int i=1;i<=n;i++)
            left[i]=right[i]=i;
            for(int i=2;i<=n;i++)
            {
                    temp=i;
                while(h[temp-1]>=h[i]&&temp>1)
                        temp=left[temp-1];
                        left[i]=temp;
            }
            for(int i=n-1;i>0;i--)
            {
                temp=i;
                while(h[temp+1]>=h[i]&&temp<n)
                    temp=right[temp+1];
                    right[i]=temp;

            }
            long long  ans=0;
            for(int i=1;i<=n;i++)
            {
                ans=max((long long )ans,h[i]*(right[i]-left[i]+1));
            }
                printf("%I64d\n",ans);

    }

}
int main()
{
   solve();
    return 0;
}


 


 

破解2559

标签:cas   min   splay   seq   sequence   string   clu   height   center   

原文地址:http://www.cnblogs.com/tlnshuju/p/6883176.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!