码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence(DP 最长上升子序列)

时间:2017-05-21 13:47:57      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:for   int   target   integer   using   define   div   reg   ble   

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 38980   Accepted: 17119

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion



n*n算法

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>

using namespace std;

int n;
int a[1001];
int dp[1010];

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        int maxx = -1;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++)
        {
            dp[i] = 1;
            for(int j=0;j<i;j++)
            {
                if(a[i]>a[j] && dp[j]+1>dp[i])
                {
                    dp[i] = dp[j] + 1;
                }
            }
            if(maxx < dp[i])
            {
                 maxx = dp[i];
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}




n*logn算法:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define inf 999999

using namespace std;

int n;
int dp[1010];
int a[1010];

int res(int len,int num)
{
    int l = 0,r = len;
    while(l!=r)
    {
        int mid = (l+r)>>1;
        if(dp[mid] == num)
        {
            return mid;
        }
        else if(dp[mid]<num)
        {
            l = mid + 1;
        }
        else if(dp[mid]>num)
        {
            r = mid;
        }
    }
    return l;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int len = 1;
        dp[0] = -1;
        for(int i=1;i<=n;i++)
        {
            dp[i] = inf;
            int k = res(len,a[i]);
            if(k == len)
            {
                len++;
            }
            dp[k] = a[i];
        }
        printf("%d\n",len-1);
    }
    return 0;
}


POJ 2533 Longest Ordered Subsequence(DP 最长上升子序列)

标签:for   int   target   integer   using   define   div   reg   ble   

原文地址:http://www.cnblogs.com/zsychanpin/p/6884550.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!