码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1013.Digital Roots【模拟或数论】【8月16】

时间:2017-05-22 10:26:35      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:strong   char s   scanf   bottom   lin   name   man   div   oid   

Digital Roots

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24 39 0
 

Sample Output
6 3
一个数。各个位数相加得到的数假设小于10就输出,否则就继续把得到的数各个位数相加。一看我就模拟做的。模拟的时候要注意。输入的数字可能非常大。所以用int是不能够的,要用字符串处理。模拟做法代码例如以下:

#include<cstdio>
#include<cstring>
void zuo(int x){
    int sum=0;
    while(x){
        sum+=(x%10);
        x/=10;
    }
    if(sum<10) printf("%d\n",sum);
    else zuo(sum);
}
int main(){
    char s[1010];
    while(scanf("%s",s)&&s[0]!=‘0‘){
        int x=0;
        for(int i=0;i<strlen(s);i++)
            x+=(s[i]-‘0‘);
        zuo(x);
    }
    return 0;
}
另一种解法。数论的知识。

数字本身:     1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  12  22  23  24  25  26  27  28  29  30············

各个位数和:  1  2  3  4  5  6  7  8  9   1   2    3     4    5    6    7    8    9    1    2    3    4    5    6   7    8    9    1    2    3·············

你会发现。每9个是一个循环。所以仅仅要对9取余就ok了。代码例如以下:

#include<cstdio>
#include<cstring>
int main(){
    char s[1010];
    while(scanf("%s",s)&&s[0]!=‘0‘){
        int x=0;
        for(int i=0;i<strlen(s);i++)
            x+=(s[i]-‘0‘);
        x=x%9;
        if(x==0) printf("9\n");
        else printf("%d\n",x);
    }
    return 0;
}



HDU 1013.Digital Roots【模拟或数论】【8月16】

标签:strong   char s   scanf   bottom   lin   name   man   div   oid   

原文地址:http://www.cnblogs.com/zsychanpin/p/6888216.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!