码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5386 Cover

时间:2017-05-24 18:29:49      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:using   insert   ret   input   namespace   break   没有   names   algorithm   

Problem Description
You have an  matrix.Every grid has a color.Now there are two types of operating:
L x y: for(int i=1;i<=n;i++)color[i][x]=y;
H x y:for(int i=1;i<=n;i++)color[x][i]=y;
Now give you the initial matrix and the goal matrix.There are  operatings.Put in order to arrange operatings,so that the initial matrix will be the goal matrix after doing these operatings

It‘s guaranteed that there exists solution.
 

Input
There are multiple test cases,first line has an integer 
For each case:
First line has two integer ,
Then  lines,every line has  integers,describe the initial matrix
Then  lines,every line has  integers,describe the goal matrix
Then  lines,every line describe an operating




 

Output
For each case,print a line include  integers.The i-th integer x show that the rank of x-th operating is 
 

Sample Input
1 3 5 2 2 1 2 3 3 2 1 3 3 3 3 3 3 3 3 3 3 H 2 3 L 2 2 H 3 3 H 1 3 L 2 3
 

Sample Output
5 2 4 3 1

这题看了题解后。感觉挺水的。。由于保证有解,所以能够从后面往前推,遇到整行的颜色和当中没有訪问过的一个操作一样的时候。就把这一行的数都变为0(即随意颜色。由于前面的颜色会被后面的覆盖),当矩阵所有为0就输出结果。

这里假设用set存储的话注意操作符的定义,由于假设定义为x或者y间的比較。可能会把一些同样的操作删除掉。导致WA.

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
int gra[106][106],c[600];
struct node{
	int f,x,y,idx;
}b,temp;
bool operator <(node a,node b){
	return a.idx<b.idx;
}

set<node>myset;
set<node>::iterator it;

int main()
{
	int n,m,i,j,T,sum,a,x,y,tot,flag,f,t,flag1,idx,num1;
	char s[10];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		sum=n*n;
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				scanf("%d",&a);
			}
		}
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				scanf("%d",&gra[i][j]);
			}
		}
		myset.clear();
		for(i=1;i<=m;i++){
			scanf("%s%d%d",s,&x,&y);
            if(s[0]==‘L‘){
            	b.f=1;
            }
            else b.f=0;
            b.x=x;b.y=y;b.idx=i;
            myset.insert(b);
		}
		t=0;
		while(1)
		{
			//if(myset.size()==0)break;// || sum==0
			if(sum==0)break;
			flag=0;
			for(it=myset.begin();it!=myset.end();it++){
				temp=*it;
				x=temp.x;y=temp.y;f=temp.f;idx=temp.idx;
				if(f==1){
					flag1=1;tot=0;
					for(i=1;i<=n;i++){
						if(gra[i][x]==0)continue;
						if(gra[i][x]==y)tot++;
						else{
							flag1=0;break;
						}
					}
					if(tot==0 || flag1==0)continue;
					
					flag=1;
					for(i=1;i<=n;i++){
						if(gra[i][x]==0)continue;
						else {gra[i][x]=0;sum--;}
					}
					t++;c[t]=idx;
					myset.erase(it);break;
				}
				
				else if(f==0){
					flag1=1;tot=0;
					for(i=1;i<=n;i++){
						if(gra[x][i]==0)continue;
						if(gra[x][i]==y)tot++;
						else{
							flag1=0;break;
						}
					}
					if(tot==0 || flag1==0)continue;
					
					flag=1;
					for(i=1;i<=n;i++){
						if(gra[x][i]==0)continue;
						else {gra[x][i]=0;sum--;}
					}
					t++;c[t]=idx;
					myset.erase(it);break;
				}
			}
			if(!flag)break;
		}
		for(i=1;i<=m;i++){
			flag=0;
			for(j=1;j<=t;j++){
				if(i==c[j]){
					flag=1;break;
				}
			}
			if(flag==0){
				printf("%d ",i);
			}
		}
		for(i=t;i>=1;i--){
			if(i==1)printf("%d\n",c[i]);
			else printf("%d ",c[i]);
		}
	}
	return 0;
}
/*
100
3 7
2 2 1
2 3 3
2 1 3
3 2 2
1 1 2
1 1 1
L 2 3
L 1 3
H 2 1
H 3 3
L 4 3
L 3 2
H 3 1
*/


hdu5386 Cover

标签:using   insert   ret   input   namespace   break   没有   names   algorithm   

原文地址:http://www.cnblogs.com/claireyuancy/p/6900114.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!