码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1579 Function Run Fun 记忆化搜索

时间:2014-08-27 16:44:18      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:c++

Description

We all love recursion! Don‘t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

按照题目要求去递归搜索   因为产生了大量的子递归(重复)  所以肯定会超时 
所以需要用到 记忆化搜索 把每个递归的a,b,c值保存起来  下次即可直接使用      
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int q[50][50][50];             //记忆化搜索 
int recursive(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
        return 1;
    if(q[a][b][c]!=0)
        return q[a][b][c];        //直接使用
    else if(a>20||b>20||c>20)
        return recursive(20,20,20);
    else if(a<b&&b<c)
        return q[a][b][c]=recursive(a,b,c-1)+recursive(a,b-1,c-1)-recursive(a,b-1,c);        // 保存
    else
        return q[a][b][c]=recursive(a-1,b,c)+recursive(a-1,b-1,c)+recursive(a-1,b,c-1)-recursive(a-1,b-1,c-1); //保存
}
int main()
{
    int a,b,c,s;
    while(cin>>a>>b>>c)
    {
        memset(q,0,sizeof(q));
        if(a==-1&&b==-1&&c==-1)
            break;
        s=recursive(a,b,c);
        printf("w(%d, %d, %d) = %d\n",a,b,c,s);
    }
    return 0;
}


POJ 1579 Function Run Fun 记忆化搜索

标签:c++

原文地址:http://blog.csdn.net/axuan_k/article/details/38870983

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!