码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1042.N!【高精度乘法】【8月24】

时间:2017-05-25 10:10:46      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:==   int   output   line   fill   margin   wrap   esc   rom   

N!

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6
高精度乘法。数组存,每一位存5位数,不然会严重超时。另外,这道题的限制时间为5s(java10s)。

代码例如以下:

#include<cstdio>
int main(){
    int n,m,t;
    while(scanf("%d",&n)==1){
        int f[8005]={0};
        f[0]=1;t=0;
        for(int i=2;i<=n;i++)
        for(int j=0;j<8005;j++){
            f[j]=f[j]*i+t;
            t=f[j]/100000;
            f[j]%=100000;
        }
        for(int i=8004;i>=0;i--)
        if(f[i]){//前面的0不用输出
            m=i;
            printf("%d",f[i]);
            break;
        }
        for(int i=m-1;i>=0;i--)
            printf("%05d",f[i]);//把0也要补起来
        printf("\n");
    }
    return 0;
}
技术分享

HDU 1042.N!【高精度乘法】【8月24】

标签:==   int   output   line   fill   margin   wrap   esc   rom   

原文地址:http://www.cnblogs.com/claireyuancy/p/6901858.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!