码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 1435 Business Cards (数论)

时间:2014-08-27 18:52:38      阅读:314      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   os   io   for   ar   div   amp   

Description

bubuko.com,布布扣

Running a paper shop is not an easy job, especially with harsh customers. Today they brought their own rectangular sheets of paper, asking you to cut it into rectangular business cards of specific size. Moreover, they require that all the paper (which may not be cheap, but is definitely not that expensive!) has to be used, i.e. no tiny bit may be left over. Moreover, the brilliant idea of cutting the sheet into very small pieces, and then gluing them together in desired sheets was laughed at.

An example of a 9×6 paper sheet divided into 2×3 cards is given below.

bubuko.com,布布扣

Input

The input contains several test cases. The first line contains the number of test cases t (tbubuko.com,布布扣105). Then t test cases follow. Each of them consists of one line containing four integers a, b, c, d (1bubuko.com,布布扣a, b, c, dbubuko.com,布布扣109). Numbers a and b are dimensions of each business card; c and d are dimensions of the paper sheet.

Output

For each test case output one line containing word `YES‘ if it is possible to divide the whole sheet into business cards, and `NO‘ otherwise.

Sample Input

4 
2 3 9 6
2 3 8 6
2 3 6 8
2 3 5 7

Sample Output

YES 
YES 
YES 
NO
题意:给你a,b,c,d四个数,问你能把c*d的矩阵分成若干个a*b的矩阵
思路:分情况讨论:1全都竖着放;2全都横着放,3交错放,注意第3种情况只能是长或者是宽是组合的,等于说就是求解ax+by=c|d的这两种情况,这个可以试着画一下。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;

int find(ll a, ll b, ll c) {
	if (a < b)	
		swap(a, b);
	for (ll i = a; i < c; i += a)
		if ((c - i) % b == 0)
			return 1;
	return 0;
}

int main() {
	ll a, b, c, d;
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%lld%lld%lld%lld", &a, &b, &c, &d);
		if ((c % a == 0 && d % b == 0) || (d % a == 0 && c % b == 0))
			printf("YES\n");
		else if (c % a == 0 && c % b == 0 && find(a, b, d))
			printf("YES\n");
		else if (d % a == 0 && d % b == 0 && find(a, b, c))
			printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


UVA - 1435 Business Cards (数论)

标签:des   style   http   os   io   for   ar   div   amp   

原文地址:http://blog.csdn.net/u011345136/article/details/38872877

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!