码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ1041 Transmitters

时间:2017-05-28 20:55:53      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:broadcast   memory   work   and   ict   rmi   double   ane   amount   

Transmitters

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don‘t overlap, or at least that they don‘t conflict. One way of accomplishing this is to restrict a transmitter‘s coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter‘s signal. Figure 1 shows the same data points with two different transmitter rotations.

技术分享

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle. 

Example input:

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5


Example output:

3
4
4


题意:用一个固定圆心坐标和半径的半圆去覆盖点,问最多能覆盖的数量

#include <bits/stdc++.h>
using namespace std;
const int N = 205;

int x, y;
double r;
int n;

int ax[N],ay[N];

int num1,num2;

void fun(int i,int j)
{
    int tmp=(ax[i]-x)*(ay[j]-y)-(ax[j]-x)*(ay[i]-y);
     //两个向量的叉积。a=(x1,y1) b=(x2,y2)
     //c=a X b=x1*y2-x2*y1
     //假设c>0。表示向量a逆时针到向量b小于PI
     //假设c<0,表示向量a顺时针到向量b小于PI
    if(tmp==0)
    {
        num1++;
        num2++;
    }
    else if(tmp>0)
    num1++;
    else
    num2++;
}

int main()
{
    while(~scanf("%d%d%lf",&x,&y,&r))
    {
        if(r<0) break;

        scanf("%d",&n);
        int cnt=0;
        int a,b;

        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            if((a-x)*(a-x)+(b-y)*(b-y)>r*r) continue;
            ax[cnt]=a;ay[cnt++]=b;
        }

        int ans=0;

        for(int i=0;i<cnt;i++)
        {
            num1=0;
            num2=0;

            for(int j=0;j<cnt;j++)
            {
                fun(i,j);
            }
             ans=max(ans,num1);
                ans=max(ans,num2);
        }

        printf("%d\n",ans);

    }

    return 0;
}


















ZOJ1041 Transmitters

标签:broadcast   memory   work   and   ict   rmi   double   ane   amount   

原文地址:http://www.cnblogs.com/cxchanpin/p/6916497.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!