码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1279 Stone Game(经典博弈)

时间:2014-08-27 22:03:38      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   java   io   strong   for   ar   

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2539    Accepted Submission(s): 741


Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
3 2 0 3 3 6 2 2 6 3 6 3 0
 

Sample Output
Case 1: Yes Case 2: No
/*
以为很难,结果看了下人家的博客还是SG函数
Time:2014-8-27 21-18
*/
#include<cstdio> 
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int Get_sg(int sum,int x){
	int D=sqrt(sum)+1;
	while(D*D+D>=sum) D--;//找到必败的临界点 
	
	if(x>D)//D*D+D=sum  D-1为必胜态,如果大于等于D,则必败,并且最小值是sum-D 
	return sum-x;//返回能取得最小值即为sg值,
	//是减去 x不是D,即最少取的个数,写错了wa了好多次 
	else
	return Get_sg(D,x);//从临界值开始再向下寻找,找到返回 
} 
int main(){
	int N;
	int d=0;
	while(scanf("%d",&N),N){
		int ans=0;
		int c,sum;
		for(int i=0;i<N;i++){
			scanf("%d%d",&sum,&c);
			ans^=Get_sg(sum,c);
		}
		printf("Case %d:\n",++d);
		if(ans)	
			printf("Yes\n");
		else
			printf("No\n");
	}
return 0;
}

杭电1279 Stone Game(经典博弈)

标签:des   style   color   os   java   io   strong   for   ar   

原文地址:http://blog.csdn.net/u013634213/article/details/38876441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!