标签:左右 end 上下 nbsp str pac mil string color
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 97281 | Accepted: 36886 |
Description
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Input
Output
Sample Input
5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
Sample Output
25
dp[i][j] = max(dp[i-1][j], dp[i+1][j], dp[i][j-1], dp[i][j+1]) + 1;
采用记忆化搜索
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 100 + 5;
int R, C;
int h[maxn][maxn];
int d[maxn][maxn];
int dx[4] = {-1, 1, 0, 0};
int dy[4] = {0, 0, -1, 1};
int dp(int x, int y)
{
int k, maxd = 0, s;
if (d[x][y] != 0)
return d[x][y]; //搜索过了就不用搜了
for (k = 0; k <= 3; k++)
{
int tx, ty;
tx = x + dx[k];
ty = y + dy[k];
if (tx < 1 || ty < 1 || tx > R || ty > C)
continue;
if (h[x][y] > h[tx][ty]) {
s = dp(tx, ty);
maxd = max(maxd, s);
}
}
d[x][y] = maxd+1;
return d[x][y];
}
int main()
{
cin >> R >> C;
int i, j, Max = 0;
memset(d, 0, sizeof(d));
for (i = 1; i <= R; i++)
for (j = 1; j <= C; j++)
cin >> h[i][j];
for (i = 1; i <= R; i++) {
for (j = 1; j <= C; j++) {
Max = max(Max, dp(i, j));
}
}
cout << Max << endl;
return 0;
}
标签:左右 end 上下 nbsp str pac mil string color
原文地址:http://www.cnblogs.com/whileskies/p/6917633.html