码迷,mamicode.com
首页 > 其他好文 > 详细

树形DP 2415HDU

时间:2017-05-29 22:16:30      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:get   rpo   possible   input   date   str   one   from   help   

Bribing FIPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 704    Accepted Submission(s): 251


Problem Description
There is going to be a voting at FIPA (Fédération Internationale de Programmation Association) to determine the host of the next IPWC (International Programming World Cup). Benjamin Bennett, the delegation of Diamondland to FIPA, is trying to seek other delegation‘s support for a vote in favor of hosting IWPC in Diamondland. Ben is trying to buy the votes by diamond gifts. He has figured out the voting price of each and every country. However, he knows that there is no need to diamond-bribe every country, since there are small poor countries that take vote orders from their respected superpowers. So, if you bribe a country, you have gained the vote of any other country under its domination (both directly and via other countries domination). For example, if C is under domination of B, and B is under domination of A, one may get the vote of all three countries just by bribing A. Note that no country is under domination of more than one country, and the domination relationship makes no cycle. You are to help him, against a big diamond, by writing a program to find out the minimum number of diamonds needed such that at least m countries vote in favor of Diamondland. Since Diamondland is a candidate, it stands out of the voting process.
 

 

Input
The input consists of multiple test cases. Each test case starts with a line containing two integers n (1 ≤ n ≤ 200) and m (0 ≤ m ≤ n) which are the number of countries participating in the voting process, and the number of votes Diamondland needs. The next n lines, each describing one country, are of the following form:

CountryName DiamondCount DCName1 DCName1 ...

CountryName, the name of the country, is a string of at least one and at most 100 letters and DiamondCount is a positive integer which is the number of diamonds needed to get the vote of that country and all of the countries that their names come in the list DCName1 DCName1 ... which means they are under direct domination of that country. Note that it is possible that some countries do not have any other country under domination. The end of the input is marked by a single line containing a single # character.

 

 

Output
For each test case, write a single line containing a number showing the minimum number of diamonds needed to gain the vote of at least m countries.
 

 

Sample Input
3 2 Aland 10 Boland 20 Aland Coland 15 #
 

 

Sample Output
20
 
主要就是建立虚根0,构造一个树,然后常规的从父节点向下进行就可以了,细节见代码

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=388;
int n,m,v[maxn];
char str1[111],str2[112],str[1155];
int dp[310][310];
bool vis[310];
vector<int>vec[maxn];
map<string,int>mp;
int dfs(int u){
    int tot=1;
    dp[u][0]=0;
    dp[u][1]=v[u];
    for(int i=0;i<(int)vec[u].size();++i){
        tot+=dfs(vec[u][i]);
        for(int j=n;j>=0;--j)    //有01背包的意思,从后面向前面
            for(int k=0;k<=j;++k)
            dp[u][j]=min(dp[u][j],dp[u][j-k]+dp[vec[u][i]][k]);
    }
    for(int i=1;i<=tot;++i)
        dp[u][i]=min(dp[u][i],v[u]);
    return tot;
}
int main(){
   while(gets(str)&&str[0]!=‘#‘){
    sscanf(str,"%d%d",&n,&m);
    int top=1,x;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<=n;++i) vec[i].clear();
    mp.clear();
    for(int i=1;i<=n;++i)
    {
        scanf("%s%d",str1,&x);
        if(!mp[str1]) mp[str1]=top++;
        v[mp[str1]]=x;
        gets(str);
        stringstream ss(str);
        while(ss>>str2) {
            if(!mp[str2]) mp[str2]=top++;
            vec[mp[str1]].push_back(mp[str2]);
            vis[mp[str2]]=1;
        }
    }
    v[0]=INF;
    for(int i=1;i<=n;++i) if(!vis[i]) vec[0].push_back(i);
    for(int i=0;i<=n;++i)
        for(int j=0;j<=n;++j)
        dp[i][j]=INF;
    dfs(0);
    printf("%d\n",*min_element(dp[0]+m,dp[0]+n+1));

   }
}

 

树形DP 2415HDU

标签:get   rpo   possible   input   date   str   one   from   help   

原文地址:http://www.cnblogs.com/mfys/p/6919142.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!