码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1157 Who's in the Middle

时间:2014-08-27 23:33:18      阅读:435      评论:0      收藏:0      [点我收藏+]

标签:hdu1157

Who‘s in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9411    Accepted Submission(s): 4538


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
5 2 4 1 3 5
 

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 

Source

水水水

#include <stdio.h>
#include <algorithm>
using std::sort;
#define maxn 10002

int arr[maxn];

int main()
{
    int n, i;
    while(scanf("%d", &n) == 1){
        for(i = 0; i < n; ++i)
            scanf("%d", &arr[i]);
        sort(arr, arr + n);
        printf("%d\n", arr[(n-1) >> 1]);
    }
    return 0;
}


HDU1157 Who's in the Middle

标签:hdu1157

原文地址:http://blog.csdn.net/chang_mu/article/details/38879181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!