码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1220 Cube

时间:2014-08-28 09:41:19      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:hdu1220

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1372    Accepted Submission(s): 1085


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
1 2 3
 

Sample Output
0 16 297
Hint
Hint
The results will not exceed int type.
 

Author
Gao Bo
由于路计算了两个方向,所以结果需要/2

#include <stdio.h>

int main()
{
    int n, a, arr[] = {0, 0, 16};
    while(scanf("%d", &n) == 1){
        if(n < 3){
            printf("%d\n", arr[n]);
            continue;
        }
        a = (n*n*n - 4) * 8;
        a += (n*n*n - 5)*12*(n-2);
        a += (n-2)*(n-2)*6*(n*n*n - 6);
        a += (n-2)*(n-2)*(n-2)*(n*n*n-7);
        printf("%d\n", a >> 1);
    }
    return 0;
}


HDU1220 Cube

标签:hdu1220

原文地址:http://blog.csdn.net/chang_mu/article/details/38893387

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!