码迷,mamicode.com
首页 > 其他好文 > 详细

poj1014+hdu1059--A - Dividing(多重背包,二进制优化)

时间:2014-08-28 09:44:39      阅读:339      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   art   

 

A - Dividing
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

 

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0‘‘. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0‘‘; do not process this line.
 

Output

For each colletcion, output ``Collection #k:‘‘, where k is the number of the test case, and then either ``Can be divided.‘‘ or ``Can‘t be divided.‘‘. 

Output a blank line after each test case.
 

Sample Input

1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output

Collection #1: Can‘t be divided. Collection #2: Can be divided.
 

 

多重背包

 m = -1 ;
            while( (1<<(m+1) )-1 < a[i] )
                m++ ;

得到m值,对应2^0 , 2^1, 。。2^(m-1) , a[i] - 2^m+1 ;优化每个组的数量

 

#include <cstdio>
#include <cstring>
#include <algorithm>
int a[10] ;
int dp[200000] ;
int main()
{
    int ans , i , j , k , t = 0 , m , s ;
    while( scanf("%d", &a[1]) )
    {
        t++ ;
        ans = a[1]*1 ;
        for(i = 2 ; i <= 6 ; i++)
        {
            scanf("%d", &a[i]);
            ans += a[i]*i ;
        }
        if(ans == 0)
            break;
        printf("Collection #%d:\n", t );
        if( ans%2 )
        {
            printf("Can't be divided.\n\n");
            continue ;
        }
        ans /= 2 ;
        memset(dp,0,sizeof(dp));
        dp[0] = 1 ;
        for(i = 1 ; i <= 6 ; i++)
        {
            m = -1 ;
            while( (1<<(m+1) )-1 < a[i] )
                m++ ;
            for(j = 0 ; j <= m ; j++)
            {
                if(j == m) s = a[i] - (1<<j) + 1 ;
                else s = 1<<j ;
                for(k = ans ; k >= i*s ; k--)
                {
                    if( !dp[k] && dp[k- (i*s) ] )
                        dp[k] = 1 ;
                    if( dp[ans] )
                        break;
                }
                if( dp[ans] )
                    break;
            }
            if( dp[ans] )
                break;
        }
        if( dp[ans] )
            printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");
    }
    return 0;
}


 

poj1014+hdu1059--A - Dividing(多重背包,二进制优化)

标签:des   style   color   os   io   strong   for   ar   art   

原文地址:http://blog.csdn.net/winddreams/article/details/38892961

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!