码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1222

时间:2017-06-01 23:42:38      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:input   --   search   script   put   using   cin   arch   ons   

 
http://acm.hdu.edu.cn/status.php?first=&pid=&user=sunowsir&lang=0&status=0
题目描述:
There is a hill with n holes around. The holes are signed from 0 to n-1.

技术分享


A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES
题目思路:
只需要判断m和n的最大公约数是否等于1即可,不等于一则永远抓不到;
代码:
/*************************************************************************
    > File Name: HDU-1222.cpp
    > Author: sunowsir
 ************************************************************************/

#include<bits/stdc++.h>
using namespace std;

int gcd(int a,int b){
    return b==0? a:gcd(b , a%b);
}

int main(){
    int m,n,N;
    cin>>N;
    while(N--){
        cin>>m>>n;
        if(gcd(m,n)!=1)  cout<<"YES"<<endl;
        else  cout<<"NO"<<endl;
    }
    return 0;
}

HDU-1222

标签:input   --   search   script   put   using   cin   arch   ons   

原文地址:http://www.cnblogs.com/sunowsir/p/6931214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!