码迷,mamicode.com
首页 > 其他好文 > 详细

Phone List(字典树)

时间:2014-08-28 11:27:49      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   ar   

Phone ListCrawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input

2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output

NO YES
题意:看是否有相同的前缀,如果有输出NO,没有输出YES
ps:注意要释放内存。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
using namespace std;
struct node
{
    int flag;
    struct node *next[10];
}tree;
struct node *root;
void create_tree(char *str)
{
    int i,j;
    int len=strlen(str);
    struct node*p=root, *q;
    for(i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if(p->next[id]==NULL)
        {
            q=(struct node*)malloc(sizeof(struct node));
            q->flag=1;//初始的flag==1;
            for(j=0;j<10;j++)
                q->next[j]=NULL;
            p->next[id]=q;
            p=p->next[id];
        }
        else
        {
            p->next[id]->flag++;
            p=p->next[id];
        }
    }
    p->flag=-1;//若为结尾,则将v改成-1表示

}

int find_tree(char *str)
{
    int i;
    int len=strlen(str);
    struct node *p=root;
    for(i=0;i<len;i++)
    {
        int id=str[i]-'0';
        p=p->next[id];
        if(p==NULL)//若为空集,表示不存以此为前缀的串
          return 0;
        if(p->flag==-1)//字符集中已有串是此串的前缀
            return -1;
    }
    return -1;//此串是字符集中某串的前缀
}

int freedom(struct node * T)//释放空间
{
    int i;
    if(T==NULL)
        return 0;
    for(i=0;i<10;i++)
    {
        if(T->next[i]!=NULL)
            freedom(T->next[i]);
    }
    free(T);
    return 0;
}

int main()
{
    char str[20];
    int n,m,i,j;
    int flag;
    scanf("%d", &n);
    while(n--)
    {
        flag=0;
        root=(struct node *)malloc(sizeof(struct node));
        for(i=0;i<10;i++)
            root->next[i]=NULL;
            root->flag=0;
        scanf("%d", &m);
        while(m--)
        {
            scanf("%s",str);
              if(find_tree(str)==-1)
                flag=1;
                if(flag)
                continue;
              create_tree(str);

        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
        freedom(root);
    }
    return 0;
}



Phone List(字典树)

标签:des   style   http   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/u013486414/article/details/38894845

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!