码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-1021 Fibonacci Again

时间:2017-06-04 19:51:54      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:判断   print   tle   script   sample   fibonacci   std   return   题意   

题目链接;

http://acm.hdu.edu.cn/showproblem.php?pid=1021

题目类型:

斐波那契数列

题意描述:

一个斐波那契数列,如果对3取余为0,输出yes,反之输出no。

解题思路:

先在全局变量定一个较大值Max为1000010,然后打表,然后在写多实例输入,判断输出即可。

题目:

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60963    Accepted Submission(s): 28487


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0
1
2
3
4
5
 

 

Sample Output
no
no
yes
no
no
no
 
# include <stdio.h>
# define MAX 1000010

int a[MAX];

int main ()
{
    int i,n;
    a[0]=7%3; a[1]=11%3;
    for(i=2;i<MAX;i++)
        a[i]=(a[i-1]+a[i-2])%3;
    while(scanf("%d",&n)!=EOF)
    {
        if(a[n]==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

 

hdu-1021 Fibonacci Again

标签:判断   print   tle   script   sample   fibonacci   std   return   题意   

原文地址:http://www.cnblogs.com/love-sherry/p/6941473.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!