码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-1159 Common Subsequence

时间:2017-06-05 00:35:22      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:tin   space   scan   contest   show   return   i++   mis   put   

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1159

题目类型:

最大公共子串

题意概括:

给出两个字符串,求这两个字符串的最大公共子串

解题思路:

通过一个二维字符串,将两个字符串进行比较,遇到相同则将左上角的值+1赋予当前位置的值,如果不相同,则将左边和上面的值的最大值赋予当前值,右下角的值即最大公共子串的长度。

题目:

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38605    Accepted Submission(s): 17735


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 

 

Sample Output
4
2
0
 
# include <stdio.h>
# include <string.h>
int dp[1010][1010];
int maxx(int a,int b)
{
    if(a>b)
        return a;
    else
        return b;
}


int main ()
{
    int i,j,l1,l2;
    
    char a[1010],b[1010];
    
    while(scanf("%s%s",a+1,b+1)!=EOF)
    {
        int l1=strlen(a);
        int l2=strlen(b);
        memset(dp,0,sizeof(dp));
        for(i=0;i<l1;i++)
        {
            for(j=0;j<l2;j++)
            {
                if(i==0 || j==0)
                    dp[i][j]=0;
                else if(a[i]==b[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                else if(a[i]!=b[j])
                    dp[i][j]=maxx(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[l1-1][l2-1]);
    }
}

 

 

hdu-1159 Common Subsequence

标签:tin   space   scan   contest   show   return   i++   mis   put   

原文地址:http://www.cnblogs.com/love-sherry/p/6942177.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!