码迷,mamicode.com
首页 > 其他好文 > 详细

【hdu3294】Girls' research——manacher

时间:2017-06-06 13:04:46      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:int   for   repr   cst   rate   content   follow   not   play   

Problem Description

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:

First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but ‘a‘ inside is not the real ‘a‘, that means if we define the ‘b‘ is the real ‘a‘, then we can infer that ‘c‘ is the real ‘b‘, ‘d‘ is the real ‘c‘ ……, ‘a‘ is the real ‘z‘. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.


Input

Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real ‘a‘ is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 
Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 
Sample Input
b babd
a abcd
 
Sample Output
0 2 aza
No solution!
 
 
其实这道题本质上就是一道裸的manacher,我们知道替换字母并不会影响它是不是回文,该是回文的还是,不是的也肯定依然不是,因此我们可以先跑一遍manacher,然后再进行字母的转换(这样可以避免对不是最长回文的字母进行无谓的转换)。
关于起始点和终止点,分别是(a-p[a]+2)/2-1(a+p[a]-2)/2-1。其中a是最长回文串的对称轴,至于这是为什么希望你能自己推导一下。
最后是这道题最特殊的地方——字母替换:
首先要输入的是一个数组,这样读到EOF时才会退出循环。
然后int k为c[0]-‘a‘,即向前进几个单位,用s[i]-‘a‘-k来表示是第几个字母,不过这样得到的可能是一个负数,所以应该是(s[i]-‘a‘-k+26)%26+‘a‘。
具体实现细节看代码。
技术分享
#include<cstdio>
#include<cstring>
#include<iostream>
const int maxn=400010;
using namespace std;
char c[2],s[maxn];
int pos,len,p[maxn],a;
int main()
{
    while(~scanf("%s %s",c,s))
    {
        len=strlen(s);pos=0;a=0;
        for(int i=len;i>=0;i--)
        {
            s[i*2+2]=s[i];
            s[i*2+1]=#;
        }
        s[0]=&;p[0]=0;
        for(int i=2;i<len*2+1;i++)
        {
            if(pos+p[pos]>i)p[i]=min(p[pos*2-i],pos+p[pos]-i);
            else p[i]=1;
            while(s[i+p[i]]==s[i-p[i]])p[i]++;
            if(pos+p[pos]<i+p[i])pos=i;
            if(p[a]<p[i])a=i;
        }
        if(p[a]-1<2)printf("No solution!\n");
        else{
            printf("%d %d\n",(a-p[a]+2)/2-1,(a+p[a]-2)/2-1);
            int k=c[0]-a;
            for(int i=a-p[a]+2;i<=a+p[a]-2;i+=2)printf("%c",(s[i]-a-k+26)%26+a);
            printf("\n");
        }
    }
    return 0;
}
View Code

 

【hdu3294】Girls' research——manacher

标签:int   for   repr   cst   rate   content   follow   not   play   

原文地址:http://www.cnblogs.com/JKAI/p/6950872.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!