码迷,mamicode.com
首页 > 其他好文 > 详细

poj2960 S-Nim

时间:2017-06-11 10:25:30      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:time   amp   set   sub   bin   ons   ever   accept   nsis   

S-Nim
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4361   Accepted: 2296

Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
  • The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
  • The players take turns chosing a heap and removing a positive number of beads from it.
  • The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they 
recently learned an easy way to always be able to find the best move:
  • Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
  • If the xor-sum is 0, too bad, you will lose.
  • Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
  • The player that takes the last bead wins.
  • After the winning player‘s last move the xor-sum will be 0.
  • The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. 
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. 
The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a ‘W‘.If the described position is a losing position print an ‘L‘. 
Print a newline after each test case.

Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output

LWW
WWL

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 105
#define M 10005

int s[N], sn;
int sg[M];

void getsg(int n)
{
    int mk[M];
    sg[0] = 0;//主要是让终止状态的sg为0 
    memset(mk, -1, sizeof(mk));
    for(int i = 1; i < M; i++)
    {
        for(int j = 0; j < n && s[j] <= i; j++)
            mk[sg[i-s[j]]]=i;//将所有后继的sg标记为i,然后找到后继的sg没有出现过的最小正整数 
                             //优化:注意这儿是标记成了i,刚开始标记成了1,这样每次需初始化mk,而标记成i就不需要了 
        int j = 0;
        while(mk[j] == i) j++;
        sg[i] = j;
    }
}

int main()
{
    while(~scanf("%d", &sn), sn)
    {
        for(int i = 0; i < sn; i++) scanf("%d", &s[i]);
        sort(s, s+sn);//排序算一个优化,求sg的时候会用到 
        getsg(sn);
        int m;
        scanf("%d", &m);
        char ans[N];
        for(int c = 0; c < m; c++)
        {
            int n, tm;
            scanf("%d", &n);
            int res = 0;
            for(int i = 0; i < n; i++)
            {
                scanf("%d", &tm);
                res ^= sg[tm];
            }
            if(res == 0) ans[c] = L;
            else ans[c] = W;
        }
        ans[m]=0;
        printf("%s\n", ans);
    }
    return 0;
}

 

poj2960 S-Nim

标签:time   amp   set   sub   bin   ons   ever   accept   nsis   

原文地址:http://www.cnblogs.com/L-Memory/p/6984175.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!