码迷,mamicode.com
首页 > 其他好文 > 详细

杭电(hdu)2053 Switch Game 水题

时间:2017-06-12 23:54:19      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:off   ack   cstring   test   12px   tle   tracking   stream   ide   

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13113    Accepted Submission(s): 7970


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
1 5
 

Sample Output
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 
測试数据量不大,能够简单粗暴,这道题也就是水题。
#include <iostream>
#include <cstring>
using namespace std;

int main()
{
	int n;
	int count;
	while(cin>>n)
	{
		count=0;
		for(int i=1;i<=n;i++)
		{
			if(n%i==0)
			{
				count++;
			}
		}
		if(count%2==0)cout<<"0"<<endl;
		else cout<<"1"<<endl;
	}
	return 0;
}


杭电(hdu)2053 Switch Game 水题

标签:off   ack   cstring   test   12px   tle   tracking   stream   ide   

原文地址:http://www.cnblogs.com/blfbuaa/p/6995170.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!