码迷,mamicode.com
首页 > 其他好文 > 详细

百练6247-过滤多余的空格-2015正式B题

时间:2017-06-14 14:27:51      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:nbsp   har   page   过滤   长度   输出   menu   标记   include   

B:过滤多余的空格

1000ms
 
内存限制: 
65536kB
描述

一个句子中也许有多个连续空格,过滤掉多余的空格,只留下一个空格。

输入
一行,一个字符串(长度不超过200),句子的头和尾都没有空格。
输出
过滤之后的句子。
样例输入
Hello      world.This is    c language.
样例输出
Hello world.This is c language.

#include <iostream>
#include <stdio.h>
#include <string>
#include <ctype.h>

using namespace std;

int main()  {
    char ju[201];
    int judge[201];
    gets(ju);
    string sen = ju;
    int l = sen.size();

    for(int i = 0; i < l; i++)  {
        if(sen[i] ==   && judge[i-1] == 0)  {
            judge[i] = 1;
        }
        else if(sen[i] ==   && judge[i-1] != 0)   {
            judge[i] = judge[i-1] + 1;
        }
        else{
            judge[i] = 0;
        }
    }

    for(int i = 0; i < l; i++)  {
        if(judge[i] == 0 || judge[i] == 1)  {
            cout << sen[i];
        }
    }

    return 0;

}

 

就是一个简单的标记方法。

百练6247-过滤多余的空格-2015正式B题

标签:nbsp   har   page   过滤   长度   输出   menu   标记   include   

原文地址:http://www.cnblogs.com/QingHuan/p/7008233.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!