码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1823 Luck and Love

时间:2014-08-29 22:44:18      阅读:402      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   java   io   strong   ar   


二维线段树模版题。。。

Luck and Love

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5397    Accepted Submission(s): 1348


Problem Description
世界上上最远的距离不是相隔天涯海角
而是我在你面前
可你却不知道我爱你
                ―― 张小娴

前段日子,枫冰叶子给Wiskey做了个征婚启事,聘礼达到500万哦,天哪,可是天文数字了啊,不知多少MM蜂拥而至,顿时万人空巷,连扫地的大妈都来凑热闹来了。―_―|||
由于人数太多,Wiskey实在忙不过来,就把统计的事情全交给了枫冰叶子,自己跑回家休息去了。这可够枫冰叶子忙的了,他要处理的有两类事情,一是得接受MM的报名,二是要帮Wiskey查找符合要求的MM中缘分最高值。
 

Input
本题有多个测试数据,第一个数字M,表示接下来有连续的M个操作,当M=0时处理中止。
接下来是一个操作符C。
当操作符为‘I’时,表示有一个MM报名,后面接着一个整数,H表示身高,两个浮点数,A表示活泼度,L表示缘分值。 (100<=H<=200, 0.0<=A,L<=100.0)
当操作符为‘Q’时,后面接着四个浮点数,H1,H2表示身高区间,A1,A2表示活泼度区间,输出符合身高和活泼度要求的MM中的缘分最高值。 (100<=H1,H2<=200, 0.0<=A1,A2<=100.0)
所有输入的浮点数,均只有一位小数。
 

Output
对于每一次询问操作,在一行里面输出缘分最高值,保留一位小数。
对查找不到的询问,输出-1。
 

Sample Input
8 I 160 50.5 60.0 I 165 30.0 80.5 I 166 10.0 50.0 I 170 80.5 77.5 Q 150 166 10.0 60.0 Q 166 177 10.0 50.0 I 166 40.0 99.9 Q 166 177 10.0 50.0 0
 

Sample Output
80.5 50.0 99.9
 

Author
威士忌
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

const double eps=1e-6;
const int maxn=2100;

int xL,xR,yL,yR,Value;
int Max[220<<2][maxn<<2];
int N,M;
int maxv;

void pushup(int xrt,int rt)
{
    Max[xrt][rt]=max(Max[xrt][rt<<1],Max[xrt][rt<<1|1]);
}

void updateY(int xrt,int x,int l,int r,int rt)
{
    if(l==r)
    {
        if(x==-1)
        {
            Max[xrt][rt]=max(Max[xrt<<1][rt],Max[xrt<<1|1][rt]);
        }
        else
        {
            Max[xrt][rt]=max(Max[xrt][rt],Value);
        }
        return ;
    }
    int m=(l+r)/2;
    if(yL<=m) updateY(xrt,x,lson);
    else updateY(xrt,x,rson);
    pushup(xrt,rt);
}

void updateX(int l,int r,int rt)
{
    if(l==r)
    {
        updateY(rt,l,1,M,1);
        return ;
    }
    int m=(l+r)/2;
    if(xL<=m) updateX(lson);
    else updateX(rson);
    updateY(rt,-1,1,M,1);
}

void queryY(int xrt,int l,int r,int rt)
{
    if(yL<=l&&r<=yR)
    {
        maxv=max(maxv,Max[xrt][rt]);
        return ;
    }
    int m=(l+r)/2;
    if(yL<=m) queryY(xrt,lson);
    if(yR>m) queryY(xrt,rson);
}

void queryX(int l,int r,int rt)
{
    if(xL<=l&&r<=xR)
    {
        queryY(rt,1,M,1);
        return ;
    }
    int m=(l+r)/2;
    if(xL<=m) queryX(lson);
    if(xR>m) queryX(rson);
}

int main()
{
    int op;char cmd[20];
    N=200;M=2100;
    while(scanf("%d",&op)!=EOF&&op)
    {
        memset(Max,-1,sizeof(Max));
        while(op--)
        {
            scanf("%s",cmd);
            if(cmd[0]=='I')
            {
                int H;
                double a,l;
                scanf("%d%lf%lf",&H,&a,&l);
                H-=99;
                int A=(int)((a+eps)*10);
                int L=(int)((l+eps)*10);
                xL=H;yL=A;Value=L;
                updateX(1,N,1);
            }
            else if(cmd[0]=='Q')
            {
                int H1,H2;
                double a1,a2;
                scanf("%d%d%lf%lf",&H1,&H2,&a1,&a2);
                int A1=(int)((a1+eps)*10);
                int A2=(int)((a2+eps)*10);
                xL=min(H1,H2)-99,xR=max(H1,H2)-99;
                yL=min(A1,A2),yR=max(A1,A2);
                maxv=-(1<<30);
                queryX(1,N,1);
                if(maxv==-1) printf("-1\n");
                else printf("%.1lf\n",maxv/10.);
            }
        }
    }
    return 0;
}



HDOJ 1823 Luck and Love

标签:des   style   http   color   os   java   io   strong   ar   

原文地址:http://blog.csdn.net/ck_boss/article/details/38931059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!