码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1009 FatMouse' Trade

时间:2017-06-21 09:36:33      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:last   javabean   contain   i++   use   sts   memory   follow   ber   

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77842    Accepted Submission(s): 26724

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.

 

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

 

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

 

 

Sample Output

13.333

31.500

 

#include<stdio.h> 
struct room
 {
     double bean;
     double cat;
     double s;
 }room[1000];
 int main()
 {
     int i,j,N;
     double M;
     struct room t;
   while(1)
     {
       double sum=0;
    scanf("%lf%d",&M,&N);
      if(M==-1&&N==-1)break;
     for(i=0;i<N;i++)
     {
         scanf("%lf%lf",&room[i].bean,&room[i].cat);
         room[i].s=room[i].bean/room[i].cat;
     }
      for(i=0;i<N-1;i++)
        for(j=i+1;j<N;j++)
       {
           if(room[i].s<room[j].s)
       {
          t=room[j];
          room[j]=room[i];
          room[i]=t;
      }
       if(room[i].s==room[j].s&&room[i].cat<room[j].cat)
      {
           t=room[j];
          room[j]=room[i];
          room[i]=t;
      }
       }
       for(i=0;i<N;i++)
       {
           if(M>=room[i].cat)
            {sum+=room[i].bean;
            M-=room[i].cat;
            }
            else
            {
                sum+=M*room[i].s;break;
            }
       }
       printf("%.3lf\n",sum);

     }
     return 0;
 }

  

Hdu 1009 FatMouse' Trade

标签:last   javabean   contain   i++   use   sts   memory   follow   ber   

原文地址:http://www.cnblogs.com/zhangliu/p/7057782.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!