码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1013 Digital Roots

时间:2017-06-21 09:46:17      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:roo   ted   har   str   dig   put   repeat   tput   bsp   

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 78669    Accepted Submission(s): 24590

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

 

Sample Input

24

39

0

 

 

Sample Output

6

3

#include<stdio.h>
#include<string.h>int main()
{
    while(1)
    {
        char c[1000];
        scanf("%s",c);
        if(strcmp(c,"0")==0)break;
        int i,sum=0;
        for(i=0;i<strlen(c);i++)
            sum+=c[i]-‘0‘;
        while(sum>9)
            sum=sum/10+sum%10;
        printf("%d\n",sum);
    }
    return 0;
}     

  

Hdu 1013 Digital Roots

标签:roo   ted   har   str   dig   put   repeat   tput   bsp   

原文地址:http://www.cnblogs.com/zhangliu/p/7057787.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!