码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1194 Beat the Spread!

时间:2017-06-21 11:37:55      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:return   rbo   imp   cores   follow   sub   include   ted   waiting   

Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7001    Accepted Submission(s): 3700

Problem Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

 

 

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

 

 

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

 

 

Sample Input

2

40 20

20 40

 

 

Sample Output

30 10

impossible

#include"stdio.h"
int main()
{
	long n,a,b,x,y,s;
 	scanf("%ld",&n);
 	while(n--)
 	{
	 	scanf("%ld%ld",&a,&b);
	  	x=(a+b)/2;
	  	y=(a-b)/2;
	  	s=a+b;    
	  	if(s%2!=0) 
			printf("impossible\n");//a+b若为奇数,则x讲不会是整数;   else if(x<0||y<0) printf("impossible\n");
	  	else
		  	printf("%ld %ld\n",x,y);
    }
	return 0;
}

  

Hdu 1194 Beat the Spread!

标签:return   rbo   imp   cores   follow   sub   include   ted   waiting   

原文地址:http://www.cnblogs.com/zhangliu/p/7057914.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!