码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1163 Eddy's digital Roots

时间:2017-06-21 11:38:28      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:iss   continue   and   nec   notice   digital   hdu   input   line   

Eddy‘s digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6826    Accepted Submission(s): 3738

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy‘s easy problem is that : give you the n,want you to find the n^n‘s digital Roots.

 

 

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

 

 

Output

Output n^n‘s digital root on a separate line of the output.

 

 

Sample Input

2

4

0

 

 

Sample Output

4

4

#include<stdio.h>
int main()
{
    int a,i,n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        a=n;
        for(i=2;i<=n;i++)//    求次方,防止数过大,每次都求九的余数             a=a*n%9;
        if(a==0)
            printf("9\n");
        else
        printf("%d\n",a);
    }
    return 0;
}

  

Hdu 1163 Eddy's digital Roots

标签:iss   continue   and   nec   notice   digital   hdu   input   line   

原文地址:http://www.cnblogs.com/zhangliu/p/7057902.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!