码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1703 PBD

时间:2017-06-21 11:45:19      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:contains   nim   accept   multiple   limit   turn   example   mission   tin   

PBD

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1065    Accepted Submission(s): 402

Problem Description

PrisonBreak is a popular TV programme in HDU. ACboy likes it very much, and he join a PrisonBreak discussing team called "PBD".Every Tuesday night, a lot of PBDers will contact with each other to discuss the newest plot of PrisonBreak season2. Generally speaking, every PBDer has distinct ideas about the play, so everyone want to know all the others‘ ideas. For example, when ACboy contract with Sam, ACboy will tell all the ideas he konws to Sam, and Sam will also tell all the ideas he konws to ACboy, and the call costs 5 yuan.
If there are N people in the "PBD" team, what is the minimum cost to let everyone knows all the others‘ ideas?

 

 

Input

The input contains multiple test cases.
Each test case contains a number N, means there are N people in the "PBD" team.N = 0 ends the input.(A call cost 5 yuan).

 

 

Output

for each case, output a integer represent the minimum cost to let everyone knows all the others‘ ideas.

 

 

Sample Input

1

2

3

4

0

 

 

Sample Output

0

5

15

20

#include<stdio.h>int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        if(n<=4)
        switch(n)
        {
            case 1:printf("0\n");break;
            case 2:printf("5\n");break;
            case 3:printf("15\n");break;
            case 4:printf("20\n");break;
        }
        else
        {
            printf("%d\n",10*n-20);
        }
    }
    return 0;
}

  

Hdu 1703 PBD

标签:contains   nim   accept   multiple   limit   turn   example   mission   tin   

原文地址:http://www.cnblogs.com/zhangliu/p/7058024.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!