码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1055 POJ2054 Color a Tree

时间:2014-08-30 17:49:09      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:hdu1055

Color a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1068    Accepted Submission(s): 349


Problem Description
Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes.

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try.

Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi.

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.

bubuko.com,布布扣

Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.
 

Input
The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed.

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.
 

Sample Input
5 1 1 2 1 2 4 1 2 1 3 2 4 3 5 0 0
 

Sample Output
33
 

Source

参考

#include <stdio.h>
#include <string.h>
#define maxn 1002

struct Node{
	int pre, c, t;
	double w;
} V[maxn];

int findMax(int n, int root)
{
	int i, u;
	double maxv = -1;
	for(i = 1; i <= n; ++i){
		if(V[i].w > maxv && i != root){
			maxv = V[i].w; u = i;
		}
	}
	return u;
}

int main()
{
	int n, root, i, ans, a, b, m, pre, j;
	while(scanf("%d%d", &n, &root), n || root){
		for(i = 1, ans = 0; i <= n; ++i){
			scanf("%d", &V[i].c);
			ans += V[i].c; V[i].t = 1;
			V[i].w = V[i].c;
		}
		for(i = 1; i < n; ++i){
			scanf("%d%d", &a, &b);
			V[b].pre = a;
		}
		for(i = 1; i < n; ++i){
			m = findMax(n, root);
			V[m].w = 0; pre = V[m].pre;
			ans += V[m].c * V[pre].t;
			for(j = 1; j <= n; ++j)
				if(V[j].pre == m) V[j].pre = pre;
			V[pre].c += V[m].c;
			V[pre].t += V[m].t;
			V[pre].w = (double)V[pre].c / V[pre].t;
		}
		printf("%d\n", ans);
	}
	return 0;
}


HDU1055 POJ2054 Color a Tree

标签:hdu1055

原文地址:http://blog.csdn.net/chang_mu/article/details/38945571

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!