码迷,mamicode.com
首页 > 其他好文 > 详细

HNU Round Robin (约瑟夫)

时间:2014-08-30 23:09:40      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   ar   for   art   

Round Robin
Time Limit: 2000ms, Special Time Limit:5000ms, Memory Limit:65536KB
Total submit users: 37, Accepted users: 30
Problem 12940 : No special judgement
Problem description

Suppose that N players sit in order and take turns in a game, with the first person following the last person, to continue in cyclic order. While doing so, each player keeps track of the number of turns he or she has taken. The game consists of rounds, and in each round T turns are taken. After a round, the player who just had a turn is eliminated from the game. If the remaining players have all had the same number of turns, the game ends. Otherwise, they continue with another round of T moves, starting with the player just after the one who was most recently eliminated.

As an example, assume we begin a game with N=5 and T=17, labeling the players in order as A, B, C, D, and E, with all counts initially zero.


Player A B C D E
Count 0 0 0 0 0

Beginning with A, 17 turns are taken. B will have taken the last of those turn, leaving our counts as follows:


Player A B C D E
Count 4 4 3 3 3

Suppose that after every 17 turns, the player who just had a turn is eliminated from the game. All remaining players then compare their counts. If all of those counts are equal, everyone has had a fair number of turns and the game is considered completed. Otherwise, they continue with another round of 17 moves starting with the player just after the one who was most recently eliminated.

Continuing with our example, B will leave the game, and the next turn will be for C.


Player A C D E
Count 4 3 3 3

After 17 more turns starting with C, we find that A, D and E received 4 turns, while C received 5 turns, including the last:


Player A C D E
Count 8 8 7 7

Then C leaves, and since the remaining counts are not all the same, a new round beings with D having the next turn.


Player A D E
Count 8 7 7


The next 17 turns start with D and end with E.   A adds 5 turns, while D and E add 6:

Player A D E
Count 13 13 13

Then E leaves.

Player A D
Count 13 13

At this point, notice that the two remaining players have the same count of 13. Therefore, the game ends. (We note that E‘s count was irrelevant to the decision to end the game.)



Input

The input will contain one or more datasets.  Each dataset will be described with a single line containing two integers, N and T, where N (2 ≤ N ≤ 100) is the initial number of  players, and T (2 ≤ T ≤ 100) is the number of turns after which the player with the most recently completed turn leaves.  Following the last dataset is a line containing only 0.


Output

There is one line of output for each dataset, containing two numbers, p and c.  At the time the game ends p is the number of players that remain in the game and c is the common count they all have.


Sample Input
5 17
7 10
90 2
0
Sample Output
2 13
5 3
45 1
Problem Source
ACM Mid-Central Programming Competition 2013

#include<stdio.h>
typedef struct nnnn
{
    int count;
    struct nnnn *next;
}node;
int MAX(int a,int b){return a>b?a:b;}
int MIN(int a,int b){return a<b?a:b;}
node *head;
void builde(int n)
{
    node *p;
    head=new node;
    head->count=0; head->next=head;
    for(int i=2;i<=n;i++)
    {
        p=new node; p->count=0;
        p->next=head->next; head->next=p;
    }
}
void find(int t,int n)
{
    int max=0,min=9999999;
    while(max!=min)
    {
        int i=1;
        head->count++;
        if(t==1)
        {
            while(i<n) head=head->next;
        }
       else while(i<t-1)
        {
             i++; head=head->next; head->count++;
        }
        head->next=(head->next)->next; n--;
        max=0,min=9999999;
        for(i=1;i<=n+1;i++)
        {
            if(max<(head->count))max=head->count;
            if(min>(head->count))min=head->count;
            head=head->next;
        }
    }
    printf("%d %d\n",n,max);
}
int main()
{
    int n,t,st;
    while(scanf("%d",&n)>0&&n)
    {
        scanf("%d",&t);
        builde(n);
        find(t,n);
    }
}

HNU Round Robin (约瑟夫)

标签:des   style   color   os   io   strong   ar   for   art   

原文地址:http://blog.csdn.net/u010372095/article/details/38948615

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!