码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 2161 - Primes (质数)

时间:2017-07-01 12:40:47      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:its   word   code   put   eof   can   rmi   inpu   art   

Primes

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8959    Accepted Submission(s): 3754


Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 
 

Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
 

Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 
 

Sample Input
1 2 3 4 5 17 0
 

Sample Output
1: no 2: no 3: yes 4: no 5: yes 6: yes
 

Source
 




AC代码:

#include <map>
#include <set>
#include <cmath>
#include <deque>
#include <queue>
#include <stack>
#include <cstdio>
#include <cctype>
#include <string>
#include <vector>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
#define INF 0x7fffffff
using namespace std;

const int maxn = 20000;
int prime[20000];

void init() {
	prime[1] = 2;
	for(int i = 2; i < maxn; i ++) 
		if(prime[i] == 0) {
			prime[i] = 1;
			for(int j = i * 2; j < maxn; j += i) {
				prime[j] = 2;
			}
		}
	prime[2] = 2;
}

int main() {
	init();
	int cas = 1;
	int a;
	while(scanf("%d", &a) != EOF) {
		if(a == 0) break;
		
		if(prime[a] == 1) {
			printf("%d: yes\n", cas ++);
		}
		else if(prime[a] == 2) {
			printf("%d: no\n", cas ++);
		}
	}
	return 0;
}







HDU - 2161 - Primes (质数)

标签:its   word   code   put   eof   can   rmi   inpu   art   

原文地址:http://www.cnblogs.com/jzdwajue/p/7101893.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!