码迷,mamicode.com
首页 > 其他好文 > 详细

百练-16年9月推免-B题-字符串判等

时间:2017-07-02 10:25:56      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:str   stream   main   ice   class   提交   ati   std   type   

2743:字符串判等

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述

判断两个由大小写字母和空格组成的字符串在忽略大小写,且忽略空格后是否相等。

输入
两行,每行包含一个字符串。
输出
若两个字符串相等,输出YES,否则输出NO。
样例输入
a A bb BB ccc CCC
Aa BBbb CCCccc
样例输出
YES

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string>
#include <ctype.h>

using namespace std;

int main()  {
    char a[101];
    char b[101];
    gets(a);    gets(b);
    string aa, bb;
    aa = a; bb = b;

    char aaa[101];  char bbb[101];

    for(int i = 0; i < aa.size(); i++)  {
        aa[i] = tolower(aa[i]);
    }
    for(int i = 0; i < bb.size(); i++)  {
        bb[i] = tolower(bb[i]);
    }

    string f = " ";
    int t = aa.find(f, 0);
    while(t != string::npos)    {
        aa.erase(t, 1);
        t = aa.find(f, 0);
    }

    t = bb.find(f, 0);
    while(t != string::npos)    {
        bb.erase(t, 1);
        t = bb.find(f, 0);
    }

    if(aa == bb)    printf("YES");
    else    printf("NO");

    return 0;
}

 

百练-16年9月推免-B题-字符串判等

标签:str   stream   main   ice   class   提交   ati   std   type   

原文地址:http://www.cnblogs.com/QingHuan/p/7105044.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!