码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1698 Just a Hook 【线段树】+【成段更新】+【lazy标记】

时间:2017-07-02 22:18:53      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:repr   标记   main   ase   ber   tar   mis   contain   actual   

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15889    Accepted Submission(s): 7897


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技术分享


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source

这题是线段树的成段更新,要用到lazy标记。也叫延迟标记。每次更新的时候不要更新究竟,仅仅是更新当前区段。然后标记下一层但不再更新。剩下的等下次查询时再更新。

//#define DEBUG
#include <stdio.h>
#define maxn 100002
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1

int tree[maxn << 2], lazy[maxn << 2];

void pushDown(int l, int r, int rt)
{	
	int mid = (l + r) >> 1;
	tree[rt << 1] = (mid - l + 1) * lazy[rt];
	tree[rt << 1 | 1] = (r - mid) * lazy[rt];
	
	lazy[rt << 1] = lazy[rt << 1 | 1] = lazy[rt];
	lazy[rt] = 0;
}

void build(int l, int r, int rt)
{
	lazy[rt] = 0;
	if(l == r){
		tree[rt] = 1; return;
	}
	
	int mid = (l + r) >> 1;
	build(lson);
	build(rson);
	
	tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
}

void update(int left, int right, int val, int l, int r, int rt)
{
	if(left == l && right == r){
		tree[rt] = val * (r - l + 1);
		lazy[rt] = val; return;
	} //include l == r
	
	if(lazy[rt]) pushDown(l, r, rt);
	
	int mid = (l + r) >> 1;
	if(right <= mid) update(left, right, val, lson);
	else if(left > mid) update(left, right, val, rson);
	else{
		update(left, mid, val, lson);
		update(mid + 1, right, val, rson);
	}
	
	tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
}

int main()
{
	#ifdef DEBUG
	freopen("../stdin.txt", "r", stdin);
	freopen("../stdout.txt", "w", stdout);
	#endif
	
	int t, n, q, cas, a, b, c;
	scanf("%d", &t);
	for(cas = 1; cas <= t; ++cas){
		scanf("%d%d", &n, &q);
		
		build(1, n, 1);
		
		while(q--){
			scanf("%d%d%d", &a, &b, &c);
			update(a, b, c, 1, n, 1);
		}
		
		printf("Case %d: The total value of the hook is %d.\n", cas, tree[1]);
	}
	return 0;
}


HDU1698 Just a Hook 【线段树】+【成段更新】+【lazy标记】

标签:repr   标记   main   ase   ber   tar   mis   contain   actual   

原文地址:http://www.cnblogs.com/mthoutai/p/7107310.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!