码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 10339 Watching Watches

时间:2017-07-03 21:15:35      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:res   sam   main   mos   nbsp   show   rom   keep   ati   

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day. The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days. This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped). Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?
Input
Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.
Output
For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.
Sample Input
1 2

0 7
Sample Output
1 2 12:00

0 7 10:17

需要的天数 day=(12*60*60)/abs(n-m)

总共走过的时间  second=(24*60*60*1.0-n)*day;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
typedef long long ll;
int n,m;
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int k=abs(n-m);
        if(k==0){
            printf("%d %d 12:00\n",n,m);
            continue;
        }
        double day=(12*60*60*1.0)/k;
        ll showtime=(ll)(day*(24*60*60-n));
        int min=showtime/60;
        showtime%=60;
        if(showtime>=30)min++;
        int h=(min/60)%12;
        min%=60;
        if(h==0) h=12;
        printf("%d %d %02d:%02d\n",n,m,h,min);
    }
    return 0;
}

 

UVA 10339 Watching Watches

标签:res   sam   main   mos   nbsp   show   rom   keep   ati   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7112814.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!