码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 11461-Square Numbers

时间:2017-07-03 22:25:07      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:格式   one   not   i++   sqrt   str   iostream   uva   second   

11461 - Square Numbers

Time limit: 1.000 seconds 

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to ?nd out how many square numbers are there between a and b (inclusive).
Input

The input ?le contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).
Sample Input
1 4

1 10

0 0
Sample Output
2

3

题意就是a-b(包括a,b)的范围内有多少个平方数。

代码:

#include<iostream>
#include<math.h>
using namespace std;
typedef long long ll;
int main(){
    ll n,m,ans,cnt,i;
    while(cin>>n>>m){
        if(n==0&&m==0)break;
            ans=0;
        for(i=n;i<=m;i++){
            cnt=sqrt(i);
        if(cnt*cnt==i)
            ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

交题的时候,用C语言交了10几次,卡我格式错误,都不知道看一下用什么交的吗?(╯‵□′)╯︵┻━┻

C语言代码,就改一下输入输出。。。

代码:

#include<stdio.h>
#include<math.h>
int main(){
    int n,m,ans,cnt,i;
    while(~scanf("%d%d",&n,&m)){
        if(n==0&&m==0)break;
        ans=0;
        for(i=n;i<=m;i++){
            cnt=sqrt(i);
        if(cnt*cnt==i)
            ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

==

 

UVA - 11461-Square Numbers

标签:格式   one   not   i++   sqrt   str   iostream   uva   second   

原文地址:http://www.cnblogs.com/ZERO-/p/7113047.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!