码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu step 7.2.2)GCD Again(欧拉函数的简单应用——求[1,n)中与n不互质的元素的个数)

时间:2017-07-03 22:35:18      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:gcd   simple   std   div   str   end   tab   lease   multiple   

题目:

GCD Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 125 Accepted Submission(s): 84
 
Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No?

Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: 
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

 
Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 
Output

            For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 
Sample Input
2
4
0
 
Sample Output
0
1
 
Author
lcy
 
Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII
 
Recommend
lcy
 


题目分析:

             欧拉函数的简单应用。本体先使用phi(n)求出[1,n]中与n互质的元素的个数,然后再使用n-phi(n)求出[1,n]中与

n不互质的元素的个数就可以。最后还须要把它自己给减掉。也就是n-phi(n)-1.


这道题须要的须要注意的是:

1、在这里,我们还回想一下"互质"的定义:

互质,公约数仅仅有1的两个整数,叫做互质整数·公约数仅仅有1的两个自然数,叫做互质自然数,后者是前者的特殊情形·。


2、关于使用预处理的方式来求欧拉值  和  使用phi(n)来求欧拉值得两种方式的选择的个人考虑:

1)当n比較小 。同一个输入例子须要多次用到phi[i]时,这时能够考虑使用预处理的方式。假设当n比較大的时候仍使用这样的方式,非常可能会直接MLE,如这道题。


2)当n比較大,同一个输入例子仅仅须要使用一个phi[i]时,这是我们能够考虑使用调用phi(i)的方式。



代码例如以下:

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;

typedef unsigned long long int longint;

longint phi(longint num) {
	longint sum = 1;
	for (long int i = 2; i <= sqrt((double long) num); i++) {
		if (num % i == 0) {
			while (num % i == 0) {
				sum *= i;
				num /= i;
			}
			sum /= i;
			sum *= (i - 1);
		}
	}

	if (num != 1) {
		sum *= (num - 1);
	}

	return sum;
}

int main(){
	int n;
	while(scanf("%d",&n)!=EOF,n){
		/**
		 * 最后为什么要减1呢?
		 * 由于这道题要求的是[1,n)中与n不互质的元素的个数,
		 * 须要把n自己给减掉.
		 */
		printf("%lld\n",n - phi(n) - 1);
	}

	return 0;
}





(hdu step 7.2.2)GCD Again(欧拉函数的简单应用——求[1,n)中与n不互质的元素的个数)

标签:gcd   simple   std   div   str   end   tab   lease   multiple   

原文地址:http://www.cnblogs.com/cynchanpin/p/7112995.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!