码迷,mamicode.com
首页 > 其他好文 > 详细

TOJ 1203: Number Sequence

时间:2017-07-03 23:53:48      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:simple   span   sig   textarea   printf   cas   out   sse   end   

1203: Number Sequence 技术分享 技术分享

Time Limit(Common/Java):1000MS/10000MS     Memory Limit:65536KByte
Total Submit: 957            Accepted:208

Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

Sample Output

Source

HDOJ

这个题可以用暴力打表,但是你不一定得到正确结果,然后啊,就挖出了一组破数据,7 7 n,这个第三项就是0了,然后都是0啊。就一直爆炸,RE、TLE各种姿势都不行的

所以循环的正确开始应该是f[3]、f[4]

#include <stdio.h>
int main(){
int a,b,n,i;
int f[55]={0,1,1};
while(scanf("%d%d%d",&a,&b,&n),a||b||n){
    f[3]=(a+b)%7;
    f[4]=(a*f[3]+b)%7;
    for(i=5;i<=n;i++){
        f[i]=(a*f[i-1]+b*f[i-2])%7;
        if(f[i]==f[4]&&f[i-1]==f[3]){
            n=(n-3)%(i-4)+3;
            break;
        }
    }
    printf("%d\n",f[n]);
}
return 0;
}

 

TOJ 1203: Number Sequence

标签:simple   span   sig   textarea   printf   cas   out   sse   end   

原文地址:http://www.cnblogs.com/BobHuang/p/7113350.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!