码迷,mamicode.com
首页 > 其他好文 > 详细

Big Event in HDU(母函数)

时间:2014-09-01 09:22:52      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   java   strong   ar   for   

                                                    Big Event in HDU

                     Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
        Total Submission(s): 23902    Accepted Submission(s): 8424


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
 

Author
lcy

题意: 题目其实理解起来就是一个把一堆数尽量分成相等的两部分,当不能分成相等的两部分时就保证A大于B;

意解: 母函数的转化,题目可以这样解,把一堆数的和累加起来,除以2,然后就像背包一样一直趋近这个数,就可以了;

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int M = 1e6 * 2; //注意范围;
int vis[M];//标记数组,标记一个数是否可以由给出的数组合得到;

struct M
{
    int a,b;
    void read()
    {
        scanf("%d %d",&a,&b);
    }
}m[100];

int main()
{
    int n;
    while(~scanf("%d",&n) && n > 0)
    {
        int sum = 0;
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            m[i].read();
            sum += m[i].a * m[i].b;
        }
        int ans = sum / 2;
        int res = 0;
        vis[0] = 1;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j <= m[i].b * m[i].a; j += m[i].a)
            {
                for(int k = 0; k <= res; k++)
                {
                    if(k > ans) break;
                    if(vis[k])
                    {
                        vis[k + j] = 1; //如果存在这样的数,则标记
                    }
                }
                res += m[i].b * m[i].a; //累加当前可以组成的最大的数
            }
        }
        for(int i = ans; i >= 0; i--)//倒着找,可以找出一组最接近的数
        {
            if(vis[i])
            {
                ans = i;
                break;
            }
        }
        printf("%d %d\n",sum - ans,ans);
    }
    return 0;
}


Big Event in HDU(母函数)

标签:des   style   color   os   io   java   strong   ar   for   

原文地址:http://blog.csdn.net/zsgg_acm/article/details/38966485

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!