码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2054 A == B ?(找小数点)

时间:2014-09-01 10:49:43      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:hdu      数学   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2054


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
1 2 2 2 3 3 4 3
 

Sample Output
NO YES YES NO

思路:

此题关键是找小数点,找到小数点把最后面无效的零去掉再比较就OK;


代码如下:

#include <cstdio>
#include <cstring>
char a[100017], b[100017];
void re(char s[])
{
    int len = strlen(s);
    int p = 0;
    for(int i = 0; i < len; i++)
    {
        if(s[i] == '.')
        {
            p = 1;
            break;
        }
    }
    if(p)
    {
        for(int i = len-1; i >= 0; i--)
        {
            if(s[i] == '0')
                s[i] = '\0';
            else
                break;
            len--;
        }
        if(s[len-1] == '.')
            s[len-1] = '\0';
    }
}
int main()
{
    while(~scanf("%s%s",a,b))
    {
        re(a);
       // printf("%s\n",a);
        re(b);
       // printf("%s\n",b);
        if(strcmp(a,b))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


HDU 2054 A == B ?(找小数点)

标签:hdu      数学   

原文地址:http://blog.csdn.net/u012860063/article/details/38975841

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!