码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2503-Babelfish-二分

时间:2017-07-07 00:51:16      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:lis   com   moved   igp   script   dog   table   pst   out   

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 44545   Accepted: 18803

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
 
题意就是输入一堆字符串,左边的对应着右边的,然后下面给出右边的,让你输出来左边的。
输入字符串的时候,碰到空行就不再输入了。就用strlen就可以。
处理字符串的时候,在这里卡住了,后来解决了,靠strcmp,sscanf。
二分二分!!!
 
代码:
#include<bits/stdc++.h>
using namespace std;
const int N=1e5+10;

struct node{
    char s1[25],s2[25];
}a[N];

int n;

int cmp(node a,node b){
    return strcmp(a.s2,b.s2)<0;                    //感觉好厉害(;′д`)ゞ
}

int main(){
    n=0;
    char str[50];
    while(gets(str)){
        if(str[0]==\0) break;
        sscanf(str,"%s%s",a[n].s1,a[n].s2);        //好厉害(;′д`)ゞ
        n++;
    }
    sort(a,a+n,cmp);
    while(gets(str)){
       int l=0,r=n,mid,flag=1;
       while(l<=r){                                //二分
        mid=(l+r)>>1;
        if(strcmp(str,a[mid].s2)==0){
           printf("%s\n",a[mid].s1);
           flag=0;
           break;
        }
        else if(strcmp(str,a[mid].s2)<0)
            r=mid-1;
        else
            l=mid+1;
       }
       if(flag)
        printf("eh\n");
    }
    return 0;
}

==

POJ2503-Babelfish-二分

标签:lis   com   moved   igp   script   dog   table   pst   out   

原文地址:http://www.cnblogs.com/ZERO-/p/7128855.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!