码迷,mamicode.com
首页 > 其他好文 > 详细

poj3061(尺取法)

时间:2017-07-08 14:13:20      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:ast   minimal   less   mis   pos   lin   length   cond   font   

Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14927   Accepted: 6312

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

 
算法设计:
技术分享

代码

import java.util.Scanner;

public class Main{

    /**
     * @param args
     */
    static int n,s;
    static int map[]=new int[100000+3];
    static int sum[]=new int[100000+3];
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner scan=new Scanner(System.in);
        int t=scan.nextInt();
        while(t>0){
            n=scan.nextInt();
            s=scan.nextInt();
            for(int i=0;i<n;i++){
                map[i]=scan.nextInt();
            }
            sovle();
            t--;
        }
        
    }
    private static void sovle() {
        // TODO Auto-generated method stub
        int res=n+1;
        int ss=0,t=0,sum=0;
        for(;;){
            while(t<n&&sum<s){
                sum+=map[t++];
            }
            if(sum<s){
                break;
            }
            res=Math.min(res, t-ss);
            sum-=map[ss++];
        }
        if(res>n){
            res=0;
        }
        System.out.println(res);
    }

}

 

poj3061(尺取法)

标签:ast   minimal   less   mis   pos   lin   length   cond   font   

原文地址:http://www.cnblogs.com/Katerina/p/7136579.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!