码迷,mamicode.com
首页 > 其他好文 > 详细

POJ Oulipo KMP 模板题

时间:2017-07-10 12:05:41      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:time   put   nat   for   case   ever   number   using   miss   

http://poj.org/problem?id=3461

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 41051   Accepted: 16547

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
KMP模板题
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
typedef long long ll;
int nex[10006];
char s[10006],p[1000006];
void get_next(char *s)
{
    nex[0]=-1;
    int i=0,k=-1;
    int len=strlen(s);
    while(i<len)
    {
        if(k==-1 || p[i]==p[k])
        {
            i++;
            k++;
            nex[i]=k;
        }
        else k=nex[k];
    }
}
void kmp(char *s,char *p)
{
    int ans=0;
    get_next(s);
    int len=strlen(p);
    int i=0,j=0;
    while(i<len)
    {
        if(j==-1 || p[i]==s[j])
        {
            i++;
            j++;
        }
        else j=nex[j];
        if(j==strlen(s)) ans++;
    }
    printf("%d\n",ans);
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s%s",s,p);
        kmp(s,p);
    }
    return 0;
}

 

 

POJ Oulipo KMP 模板题

标签:time   put   nat   for   case   ever   number   using   miss   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7144842.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!