码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5100 Chessboard 用 k × 1 的矩形覆盖 n × n 的正方形棋盘

时间:2017-07-10 14:36:58      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:margin   des   strong   led   while   打开   sea   targe   coder   


Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 335    Accepted Submission(s): 168


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T (T10000). 
In the next T lines contain T cases , Each case has two integers n and k. (1n,k100)
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
2 6 3 5 3
 

Sample Output
36 24
 

Source
 
用 k × 1 的小矩形覆盖一个 n × n 的正方形棋盘,问正方形棋盘最多能被覆盖多少。
规律就是:假设n<k。肯定不行。
定义mod=n%k;
假设(mod<=k/2),结果为:n*n-mod*mod;
否则结果为:n*n-(k-mod)*(k-mod);
//0MS	228K
#include<stdio.h>
int main()
{
    int t,n,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        if(n<k){printf("0\n");continue;}
        int mod=n%k;
        if(mod<=k/2)printf("%d\n",n*n-mod*mod);
        else printf("%d\n",n*n-(k-mod)*(k-mod));
    }
    return 0;
}


HDU 5100 Chessboard 用 k &#215; 1 的矩形覆盖 n &#215; n 的正方形棋盘

标签:margin   des   strong   led   while   打开   sea   targe   coder   

原文地址:http://www.cnblogs.com/gavanwanggw/p/7145372.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!