码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-2251 Dungeon Master

时间:2017-07-10 16:40:00      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:class   namespace   block   ssi   front   and   sid   quick   cte   

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take?
 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#‘ and empty cells are represented by a ‘.‘. Your starting position is indicated by ‘S‘ and the exit by the letter ‘E‘. There‘s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
 

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s). 

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!



#include <iostream>
#include <queue>
using namespace std;

char maze[31][31][31];
int l, r, c;
int sx, sy, sz, gx, gy, gz;
int dx[6] = {0, 1, 0, -1, 0, 0};
int dy[6] = {1, 0, -1, 0, 0, 0};
int dz[6] = {0, 0, 0, 0, 1, -1};


typedef struct P
{
    int z;
    int x;
    int y;
    
}P;

int main(void)
{
    int bfs(void);
    
    while(scanf("%d%d%d", &l, &r, &c) == 3 && l && r && c)
    {
        for(int i = 0; i < l; i++)
        {
            for(int j = 0; j < r; j++)
            {
                scanf("%s", maze[i][j]);
                for(int k = 0; k < c; k++)
                {
                    if(maze[i][j][k] == ‘S‘)
                    {
                        sx = j;
                        sy = k;
                        sz = i;
                    }
                    if(maze[i][j][k] == ‘E‘)
                    {
                        gx = j;
                        gy = k;
                        gz = i;
                    }
                    
                }
            }
        }
        
        int e = bfs();
        if(e == -1)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n", e);
        
        
        
    }
    
    
    
    return 0;
}



int bfs(void)
{
    queue<P> que;
    int data[31][31][31];
    P cas;
    
    memset(data, -1, sizeof(data));
    
    data[sz][sx][sy] = 0;
    cas.z = sz;
    cas.x = sx;
    cas.y = sy;
    que.push(cas);
    
    while(que.size())
    {
        P ca;
        ca = que.front();   que.pop();
        if(ca.z == gz && ca.x == gx && ca.y == gy)
            break;
        
        for(int i = 0; i < 6; i++)
        {
            cas.z = ca.z + dz[i];
            cas.x = ca.x + dx[i];
            cas.y = ca.y + dy[i];
            if(cas.z >= 0 && cas.z < l && cas.x >= 0 && cas.x < r && cas.y >= 0 && cas.y < c && maze[cas.z][cas.x][cas.y] != ‘#‘ && data[cas.z][cas.x][cas.y] < 0)
            {
                que.push(cas);
                data[cas.z][cas.x][cas.y] = data[ca.z][ca.x][ca.y] + 1;
            }
            
        }
        
        
    }
    
    
    return data[gz][gx][gy];
}

 

POJ-2251 Dungeon Master

标签:class   namespace   block   ssi   front   and   sid   quick   cte   

原文地址:http://www.cnblogs.com/limyel/p/7146010.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!