码迷,mamicode.com
首页 > 其他好文 > 详细

2017ecjtu-summer training #3 POJ3264

时间:2017-07-11 00:51:12      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:class   lis   should   not   pre   c代码   neu   ups   span   

                                                                                                                                                     Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 53868   Accepted: 25299
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意 求区间最大值、最小值差
此题可用线段树求解 注意,数组开足够大,输入输出用scanf printf 用cin,cout会超时,没办法本人太菜,不会用其他牛X算法QAQ

AC代码

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAX 200000
using namespace std;
typedef long long ll;
struct node
{
int l,r;
int Max,Min;
}tree[MAX];
int a[MAX];
int qmax,qmin;
void build(int i,int l,int r)
{
tree[i].l=l;
tree[i].r=r;
if(l==r)
{
tree[i].Max=tree[i].Min=a[l];
return;
}
int mid=(r+l)>>1;
build(i<<1,l,mid);
build(i<<1|1,mid+1,r);
tree[i].Max=max(tree[i<<1].Max,tree[i<<1|1].Max);
tree[i].Min=min(tree[i<<1].Min,tree[(i<<1)|1].Min);
}
void query(int i,int l,int r)
{
if(tree[i].l==l&&tree[i].r==r)
{
qmax=max(qmax,tree[i].Max);
qmin=min(qmin,tree[i].Min);
return;
}
int mid=(tree[i].l+tree[i].r)>>1;
if(r<=mid)
query(i<<1,l,r);
else if(l>mid)
query(i<<1|1,l,r);
else
{
query(i<<1,l,mid);
query(i<<1|1,mid+1,r);
}
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
build(1,1,n);
while(m--)
{
int r,l;
scanf("%d%d",&l,&r);
qmax=-INF,qmin=INF;
query(1,l,r);
printf("%d\n",qmax-qmin);
}
}
return 0;
}

2017ecjtu-summer training #3 POJ3264

标签:class   lis   should   not   pre   c代码   neu   ups   span   

原文地址:http://www.cnblogs.com/stranger-/p/7148344.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!