码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1312 Red and Black (BFS)

时间:2014-09-01 17:43:43      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:hdu


Red and Black
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output

45 59 6 13
 

题目大意:

问最多能走‘.’多少步,‘#’是墙,不能走。

解题思路:

BFS.

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;

const int maxN=25;
int dirI[4]={1,0,-1,0},n,m,is,js;;
int dirJ[4]={0,1,0,-1},visited[maxN][maxN];
string str[maxN];

struct node{
    int i,j;
    node(int i0=0,int j0=0){
    i=i0,j=j0;
    }
};

void bfs(){
    queue <node> path;
    visited[is][js]=1;
    path.push(node(is,js));
    int cnt=1;
    while(!path.empty()){
        node s=path.front();
        path.pop();
        for(int i=0;i<4;i++){
            int di=s.i+dirI[i],dj=s.j+dirJ[i];
            if(di<0||dj<0||di>=n||dj>=m||str[di][dj]=='#') continue;
            if(visited[di][dj]==1) continue;
            visited[di][dj]=1;
            path.push(node(di,dj));
            cnt++;
        }
    }
    printf("%d\n",cnt);
}

int main(){
    while(scanf("%d%d",&m,&n)!=EOF&&n&&m){
        memset(visited,-1,sizeof(visited));
        for(int i=0;i<n;i++){
            cin>>str[i];
            for(int j=0;j<m;j++){
                if(str[i][j]=='@'){
                    is=i,js=j;
                }
            }
        }
        bfs();
    }
    return 0;
}




HDU 1312 Red and Black (BFS)

标签:hdu

原文地址:http://blog.csdn.net/hush_lei/article/details/38982653

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!