码迷,mamicode.com
首页 > 其他好文 > 详细

Dollars(简单DP)

时间:2014-09-01 17:56:53      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:dp

J - Dollars
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

bubuko.com,布布扣


 Dollars 

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 bubuko.com,布布扣 20c, 2 bubuko.com,布布扣 10c, 10c+2 bubuko.com,布布扣 5c, and 4 bubuko.com,布布扣 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293


简单DP,注意double强制转换会缺失精度,注意到数据的输入有特性,用整数读入;

AC代码:
      
#include <iostream>
#include <cstdio>

using namespace std;

long long dp[33000];
int a[15] = {5,10,20,50,100,200,500,1000,2000,5000,10000};

int main()
{
//    freopen("in.txt","r",stdin);
//    double s,n;
    dp[0] = 1;
    for(int i = 0; i < 11; i++)
        for(int j = 5; j <= 30000; j += 5)
            if(j >= a[i])
                dp[j] += dp[j - a[i]];
    int a,b;
    while(~scanf("%d.%d",&a,&b)) //不能用double读入
    {
        long long x=a*100+b;
        if(x==0)break;
        printf("%6.2lf%17lld\n",(double) x / 100.0,dp[x]);
    }
    return 0;
}


Dollars(简单DP)

标签:dp

原文地址:http://blog.csdn.net/zsgg_acm/article/details/38980795

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!